Ex1/Ex2: Makefile cc not found


#1

Hello there!

Okay, so yesterday I started with the first exercise, which did more or less work out fine, but in the aftermath, it doesn’t seem so.

I have downloaded Cygwin and work with it. I created the file ex1.c as told. I wanted to use make ex1 but it keeps saying cc: Command not found. I found out that I am missing a Compiler it seems - no problem, I tried with typing in gcc -Wall -g ex1.c -o ex1 and it created my ex1.exe without any problem. I then tried to work on my Makefile and tried to change cc to gcc by either writing CC = gcc or cc=gcc without success on either.
It seems, that my compiler has a problem with my makefile? Whenever I extract the commands from the makefile and use them directly, it works without the slightest problem, but when I write make ex1 it doesn’t find the cc command. When I write make clean, it doesn’t know what to do with clean.

I’ve searched the Internet on that topic and what it might be but with no success either.

What kind of problem might that be? Wrong path? (Because echo $PATH works) A problem with the Makefile? (I used Notepad++ and chose makefile for the language so it saved as .mak). Is it a compiler problem although gcc works?

Thanks in advance!


#2

Can you post your makefile so we can see what you’re trying?