Ex50 app.py /hello not working

when i run the app.py with the following the index page comes up

@app.route("/")

but not the name page

when i run with this

@app.route("/hello")

i get nothing at all
no debugging nothing
cant for the life of me figure this out :thinking:

here is full code

nvm im an idiot :expressionless:

Hey Chris, if you figured it out can you please write a reply explaining what the problem was? That’ll help people who might have had the same problem. Thanks.

Hi Zed,

I really was an idiot with this one,
i think i was getting a bit tired as well.

i missed the comment saying go to this url http://localhost:5000/hello instead of http://localhost:5000/

and its for ex 51 not 50. :expressionless:

That makes sense. Trust me, I’m currently trying to fix a bug that’ll probably end up being something dumb like that.

Yeah i could absolutely see how easy it is to miss something small,
that ends up being the cause of so many frustrations.

Especially when your tired or you have thousands of lines of code.

Really drives home the point of clean and understandable coding,
not only for others but yourself as well.

1 Like
A free service run by Zed A. Shaw for learncodethehardway.org.