Exercise 46: (solved) kinda stuck, is it me or an install issue

I think I fixed it but I do not understand what I did. From what I understand (which is very limited), I installed virtualenv as a a superuser with the sudo pip3.6 install virtualenv command. Then it won’t work since I’m just a regular user account? I’m not sure if that’s what happened but I’m just glad whatever I did it is now working (so far).

Blockquote
Hello folks. I manage to get through up to this exercise on my own and just scouring the internet for answers. Exercise 46 stopped me right away though in the very beginning. I am having issues with installation. Now what bugs me is that the install went fine (so far) on MacOS but on my Linux computer, I am dead in the water. Any insights or to point me anywhere to find the answer(s) would be appreciated.

I’m trying to install virtualenv and it said it is installed but following the instructions on the book, i get this ModuleNotFoundError. I have below a copy and paste of where I get stuck. Please let me know if I need to provide any more information. Again this works on my MacOs computer but not the Linux desktop. I did almost all the exercises using my desktop and would love to know what I am doing wrong. A little warning, I am a beginner so pardon me when I am a bit clueless sometimes. Thank you!

Blockquote

@test:~/Documents/lpthw$ pip list
Package                 Version
----------------------- --------------
(other packages)
nose                    1.3.7
pip                     20.3.4
virtualenv              20.13.0
(other packages)
@test:~/Documents/lpthw$ mkdir ~/.venvs
@test:~/Documents/lpthw$ virtualenv --system-site-packages ~/.venvs/lpthw
ModuleNotFoundError: No module named 'virtualenv.activation.xonsh'
@test:~/Documents/lpthw$
A free service run by Zed A. Shaw for learncodethehardway.org.