Get error while using help(ex25) in ex25

You’re going to have to explain this more. What is your problem? What are you trying to do? What have you tried to solve this? How long did you work on a solution?

All the code was running alright only problem was with using the help(ex25) and help(ex25.break_words) in the powershell. The help() function without the arguments was running fine.
One of the solutions I found online suggested to include the path of the file to environment variable which I tried.
The other solution suggested that there might be some problem with my python installation so I reinstalled the python but it didn’t work.

I found the solution which suggested ensuring if the file exists in the system32 folder and if it does add the path of the folder(system32) to the system variables. And it worked for me.

Can you explain this more? Do you mean, you previously had this file:


Then, when attempting to import it and get help, your Python shell (not powershell, remember, you ran python, not powershell) printed out “more is not recognized”.

So your solution was to move the file C:\Users\Aden\lpthw\ to your Sytem32 directory?

If so, that’s really not a solution, but confirm I’m reading your reply right so I can see how to fix it.

Also, the reason that help() prints out that message is on windows there’s no “more” command, but python stupidly thinks you’re on unix and tries to run it anyway. Can you also tell me where you got your python?