Question about seminar 1


#1

@zedshaw, in Vim School seminar 1, you mentioned that the Windows port of Vim was “terrible.” Why is that? I have Vim on a Windows machine, but I’ve used it on a Mac and in a Linux VM, and haven’t noticed any differences.


#2

So, all the Vim’s seem to use some kind of “terminal emulator” to run vim but inside a GUI window. If you do it in Linux it’s the GTK one and it’s tightly integrated and works really well. If you use the MacVim distro it’s also really tightly integrated and works really well as a GUI running vim. You don’t really even notice them doing any kind of “emulation”, and I’m not even sure the Linux one is doing that.

When I tried to use the Windows one it was incredibly clunky. Like it literally was just bit of a skin of a terminal emulator and not much else in the way of integration with Windows. A lot of the settings didn’t work, the screen was constantly getting out of sync and messed up if I resized, and all sorts of weirdness. It honestly looked like it was some build from 10 years ago on an old Windows API and they just haven’t updated yet.

So I do all of my vim in the Windows Subsystem for Linux bash shell and it works much better.

However, last time I did try the Windows Vim build was about 2 years ago, and projects change all the time so if you tried it and it worked great then let me know. I may have to go give it a shot in the Seminar 2 for Vim School just to see how it works.


#3

Regarding settings and resizing not working, they seem to have fixed it. I have a bunch of options set in my .vimrc that seem to work fine. I normally have my Powershell window large enough to not need to resize, but I tried resizing the window anyways, and it didn’t seem too out of whack. That probably depends on the file size, though, and I was using a fresh buffer. Other than that? I haven’t seen any real weirdness. Usually, if something goes wrong for me, it’s because I messed something up.


#4

Oh, are you just running it inside powershell or using the vim.exe download from them? I’m referring to the vim.exe download.

I…actually never tried it in PowerShell. Should probably go do that.


#5

No bash, WSL, Cygwin, etc. — just the .exe in PowerShell. gVim seems to work fine too.


#6

Hmmm, I will have to try it again then. I’ll fire it up today for the VimSchool 2 and give you a shoutout if it works.