SOLVED - LPTHW3 ex43 will not run in powershell

I’ve been going through lpthw3 and wrote the code for ex43. Unfortunately when I run it powershell simply seems to execute it with zero feedback. It doesnt prompt a new line for me to write in, but also doesnt give an error message, it just seems like the console is loading something forever and never finishes
Here is a link to my code:

I feel it must be me having made a mistake in my code, but I’ve gone over the whole thing about 10 times now…could it be a problem with my computer?


I run it with this: python “Gothon game”

and get this error:

File “Gothon game”, line 73
elif action == “dodge!”:
IndentationError: unindent does not match any outer indentation level

I was expecting to get zero feedback as you did, but am getting something different, I’m not sure at this stage

I run all my scripts the same way so i doubt that would be the problem, but here’s the way i ran it in powershell (windows):
Since i save it as


After I press enter the flicking underscore that shows where your next input will be simply goes to the next line and waits there, as if loading a program, except it won’t budge from there, other than continuously flicking as usual.

I finally found the missing parts:
line 26: was missing “.enter()”
line 164 was missing "return ‘death’ "

Nice, glad you figured it out. Any time you get a “the script does nothing” error it’s usually one of these things:

  1. You didn’t really save the file. Go back and force save everything.
  2. You forgot some control flow logic. That could be like what you have here, where you didn’t return something, or you forgot to call a function.
  3. You have spelled “main” wrong in the standard Python script test.

If you want to trace your program easily you can run it under pdb:

python3.6 -m pdb

You can read about pdb here:

But you basically type:


Then hit enter and watch each line run.