Unzipping the download videos from the informit

I have Linux as my OS. I get two files ‘Shaw_DVD.zip’ and ‘Shaw_DVD.zip.part’. I can’t unzip either of them. When I run the command ‘unzip’ in the terminal I get this error:-

Archive: Shaw_DVD.zip.part
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
unzip: cannot find zipfile directory in one of Shaw_DVD.zip.part or
Shaw_DVD.zip.part.zip, and cannot find Shaw_DVD.zip.part.ZIP, period.

I have downloading the files more than once to make sure it was not an incomplete download. I still got the same error.

That simply means you have to wait for the download, or your download was interrupted. The .part is the actual contents of the file while it’s being downloaded. The .zip is just a name place-holder that should be empty until the .part is fully downloaded. Then, when it’s down and safely stored, your browser will move the .part to the .zip and replace it. I’m not really sure why they do this other than it might make it more reliable but I doubt that.

So, just head back and download then go hang out for a while until it’s done.

1 Like

Thanks. I was finally able to extract the content from the ISO file.